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Introduction
This whitepaper covers two drive technologies that are provided on the HP Compaq dc7800 Business PC 
products, AHCI and RAID. This whitepaper provides a basic overview of AHCI and RAID technology, sup-
ported factory configurations of HP Compaq dc7800 Business PCs, other supported RAID configurations, 
and basic instructions on how to migrate non-RAID to RAID configurations in the field. HP also provides a 
Smart IV Hard Drive technical whitepaper for HP Compaq dc7800 Business PC products on HP.com.

Advanced Host Controller Interface (AHCI) functionality provides customer benefits such as NCQ, which 
is intended to increase the performance of the hard disk drive. HP Compaq dc7800 Business PC products 
provide support for AHCI in single and multiple drive configurations.

RAID (Redundant Array of Independent Disks) is a category of hard drives that employ two or more drives 
in combination for fault tolerance and performance. Initially used with servers, desktop PCs are increas-
ingly using RAID by adding a RAID controller and extra IDE or SCSI disks. Newer system boards often 
have RAID controllers. 

RAID technology takes advantage of Serial Advanced Technology Attachment (SATA) and the integration 
of RAID into the Intel Q35/ICH9-D0 chipset. This white paper provides a basic overview of RAID technol-
ogy, supported factory configurations of HP Compaq dc7800 Business PCs, other supported RAID config-
urations, and basic instructions on how to migrate non-RAID to RAID configurations in the field.

Basics of AHCI and RAID Technology

Definitions
Table 1 Basic AHCI and RAID Definitions 

AHCI Advanced Host Controller Interface, a specification for hardware and software, is a regis-
ter interface for SATA, intended to add higher speed, NCQ and other features

ATA Advanced Technology Attachment.

BIOS Basic Input/Output System, also known as system ROM.

Chipset Term used to define a collection of integrated components required to make a PC function.

HDD Hard disk drive.

ICH Intel Input/Output Controller Hub, inside this component resides the mass storage controller. 
ICH is part of the Intel Q35 chipset.

IDE Integrated Drive Electronics.

INF Information file (.inf) used by Microsoft operating systems that support the Plug & Play feature. 
When installing a driver, this file provides the operating system needed information about driver 
filenames, driver components, and supported hardware.
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Single Drive AHCI Configuration
To take advantage of single drive AHCI support, a change is required in F10 setup. To run a single drive 
configuration on HP Compaq dc7800 Business PCs in AHCI mode:

1. Turn on or restart the computer by clicking Start > Shut Down > Restart the Computer.

2. Press F10 as soon as the monitor light turns green.

If you do not press F10 at the appropriate time, you must restart the computer, and then press F10 
again to access the utility.

3. Select your language from the list, and then press Enter.

4. Use the arrow keys to select Storage. 

5. Use the down arrow key to select Storage Options, and then press Enter.

6. Change SATA Emulation from IDE to RAID.

NOTE: Make sure the Intel Matrix Storage driver is loaded in the SW image prior to making the F10 
setup change. The operating system will not boot without this driver. The dc7800 factory SW image 
already contains this driver. This driver is also provided as a softpaq at www.hp.com.

Single Drive AHCI Configurations are supported on the dc7800 SFF and dc7800 CMT products.

Migration Term used to describe the movement of data from one configuration or usage model to another.

NCQ Native Command Queuing.

Option ROM Piece or software module inside the System BIOS which provides extended support for a partic-
ular piece of hardware. The RAID Option ROM provides boot support for RAID volumes as well 
as a user interface for managing and configuring the systems RAID volumes.

PCI Peripheral Components Interface.

PCIe PCI express. A serial version of PCI.

PnP Plug and Play.

RAID Redundant Array of Independent Disks.

ROM Read Only Memory.

SATA Serial ATA.

Strip Set of data on a single hard drive in a RAID volume.

Stripe Group of all strips going horizontally across all the hard drive members of a RAID volume.
4



Basic RAID Types
This section provides a brief explanation of the supported RAID configurations for HP Compaq dc7800 Busi-
ness PCs.

RAID 0 with two hard drives (Striped)
Even though HP supports RAID 0, it is not the recommended configuration for business PC users. Lack of 
redundancy causes less than half the reliability of a single hard drive system since the Mean Time 
Between Failure (MTBF) of RAID 0 is equal to the MTBF of an individual drive, divided by the number of 
drives.

Table 2 RAID 0 with two hard drives (Striped)

In the previous table, each “Data Segment n” represents a group of data, known as a strip. In this case, 
each row represents a stripe. RAID 0 represented in the table above shows how information is segmented, 
made into chunks or strips, and stored across the stripes of the hard drive members of this RAID volume.

To better illustrate the concept of RAID 0 and striping, the following graphic shows how a sequence of 
data “ABCD...” is stored in a RAID 0 mode. In this example, each letter represents a segment or strip. The 
graphic shows how the various pieces of the information go to different hard drives. If any segment of 
RAID 0 fails, all information from all members is lost.

First Disk Second Disk

Data Segment 1 Data Segment 2

Data Segment 3 Data Segment 4

Data Segment 5 Data Segment 6

Data Segment 7 Data Segment 8

Data Segment 9 Data Segment 10

Data Segment 11 Data Segment 12

Data Segment 13 Data Segment 14

Data Segment 15 Data Segment 16
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Figure 1 Performance - RAID 0 with two hard drives

At a higher reliability cost with faster performance, the HP Compaq dc7800 Business PC Convertible 
Minitower also allows for RAID 0 with three hard drives. RAID 0 with two or three hard drives is a sup-
ported configuration.

RAID 0 with three hard drives is shown in the following figure:

Figure 2 RAID 0 - Three hard drives
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RAID 1 with two hard drives (Mirror)
Because it is a very cost-effective way to increase system storage reliability and a great value proposition, 
RAID 1 is the only RAID configuration that HP preconfigures for HP Compaq dc7800 Business PCs. RAID 
1 provides high availability with minimal performance impact, as well as greater reliability compared to 
a single hard drive configuration.

RAID 1 has redundancy and hence is a true RAID. It more than doubles reliability because the MTBF of 
RAID 1 is equal to the MTBF of an individual drive multiplied by the number of drives (2). In other words, 
the probability of one hard drive failure on a given day is the square root of that same probability. Hypo-
thetically, if the chances that a single hard drive fails is 1:2000, with RAID 1 the chance that both of your 
hard drives fail is 1:4,000,000.

Mirroring, segmentation, and striping have no real meaning in RAID 1. In the table and graphic, the data 
is arranged in rows for representation of different pieces of data.

Table 3 RAID 1 with two hard drives (Mirror) 

In the previous table, each “Data Segment n” represents a group of data, known as a strip. In this case, 
each rows represent a stripe. This table shows how information is duplicated in both hard drives. The size 
of the strips is mostly irrelevant and not a configurable option.

To better illustrate the concept of RAID 1 and mirroring, the following figure shows how a sequence of 
data “ABCD...” is stored in a RAID 1 volume. In this example, each letter represents a data segment. The 
graphic shows how the various pieces are replicated for both of the hard drives; hence, if any one mem-
ber of the RAID 1 volume fails, the information is kept in the surviving members. After a hard drive failure, 
the user interface sends a notification so the failed hard drive can be replaced. No user information is lost 
in this scenario.

First Disk Second Disk

Data Segment 1 Data Segment 1

Data Segment 2 Data Segment 2

Data Segment 3 Data Segment 3

Data Segment 4 Data Segment 4

Data Segment 5 Data Segment 5

Data Segment 6 Data Segment 6

Data Segment 7 Data Segment 7

Data Segment 8 Data Segment 8
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Figure 3 Reliability: RAID 1 - Mirroring

RAID 5 with three hard drives
RAID 5 has been used in servers for many years and is one of the most common types of RAID. RAID 5 
uses striping with parity data in distributed blocks across all member disks. Therefore, the mass storage 
controller can simultaneously write new information to two hard drives and parity information to the third 
hard drive, so if one hard drive fails, the RAID controller can rebuild all the information after the volume 
degradation occurred. Hence, RAID 5 with three hard drives has similar performance to RAID 0 with two 
hard drives, and the reliability of RAID 1 with a minimum of three hard drives.
8



Table 4 RAID 5 with 3 hard drives (Parity)

In the previous table, each “Data Segment x” represents a strip. A stripe is made with strip “Data Segment 
x”, “Data Segment y” and strip “Parity for x and y.”  Notice that the strip “Parity for x and y” is used to 
store the required information to recreate the data if any one of the RAID volume members is compro-
mised.

To better illustrate the concept of RAID 5 (parity based RAID), the following figure shows how a sequence 
of data “ABCD...” is stored in a RAID 5. In this example, each letter represents a segment or strip. The fig-
ure shows how the various pieces of the information go to different hard drives, hence if any one member 
of the RAID 5 fails, the information from all members is not lost.

Figure 4 RAID 5 with three hard drives

First Disk Second Disk Third Disk

Data Segment 1 Data Segment 2 Parity for 1 and 2

Data Segment 3 Parity for 3 and 4 Data Segment 4

Parity for 5 and 6 Data Segment 5 Data Segment 6

Data Segment 7 Data Segment 8 Parity for 7 and 8

Data Segment 9 Parity for 9 and 10 Data Segment 10

Parity for 11 and 12 Data Segment 11 Data Segment 12

Data Segment 13 Data Segment 14 Parity for 13 and 14

Data Segment 15 Parity for 15 and 16 Data Segment 16

Parity for 17 and 18 Data Segment 17 Data Segment 18
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Intel Matrix Storage Technology
This technology provides protection against data loss from a hard drive failure and faster access to digital 
photo, video, and music files by supporting NCQ as well as RAID 0, 1, 5, and 10. Matrix RAID enables 
two RAID levels to be combined for data loss protection plus performance. Intel Matrix Storage Technol-
ogy was previously known as Intel Application Accelerator 4.x and Intel Application Accelerator RAID 
Edition 3.x.

Figure 5 Matrix RAID combining reliability and performance with the same two hard drives

Using Intel Matrix Storage technology, you can configure the HP Compaq dc7800 Business PC Convert-
ible Minitower with two RAID volumes using three hard drives - a RAID 0 volume for ultimate perfor-
mance, and a second volume as RAID 5 with reliability and performance improvements.
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Figure 6 Matrix RAID combining reliability and performance with same three hard drives

Configurations 

Recommended configurations
HP recommends factory configurations of the preinstalled RAID offerings for HP Compaq dc7800 Busi-
ness PCs.

The preinstalled RAID offering is a RAID 1 volume of two identical SATA hard drives with the following 
customer choices:

• Two SATA 80GB 7200RPM drives

• Two SATA 250GB 7200RPM drives

• Two SATA 500GB 7200RPM drives

• Two SATA 80GB 10000RPM drives

• Two SATA 160GB 10000RPM drives
11



Hardware and firmware support is present to take advantage of the future Microsoft Vista operating sys-
tem. Intel Matrix Storage Technology RAID software support for Microsoft Vista will be available at a later 
date.

HP Compaq dc7800 Business PCs are based on the Intel Q35/ICH9-DO RAID chipset, which is a com-
bined hardware and software RAID solution. The Intel ICH9-DO SATA mass storage controller allows all 
drives to operate in IDE or RAID SATA modes. Each mode of the controller means a different PCI control-
ler, with different device ID, class code, and driver support. 

NOTE: HP recommends and only supports Microsoft’s IDE driver stack based on the ATAPI.SYS driver for 
HP Compaq Business PC products including all supported RAID configurations.

WARNING: The PCI Device ID of the mass storage controller changes after changing IDE mode. Chang-
ing the BIOS from IDE mode to RAID mode is the equivalent of connecting the hard drives to a new add-
on RAID storage controller. The installed operating system on the hard drive is unaware of this new mass 
storage controller. If the operating system does not have the RAID drivers enumerated and PnP for the 
RAID controller, the operating system will fail to boot (blue screens) when Microsoft XP or Microsoft Vista 
attempts to boot.

Table 5 RAID Drives

Mode Purpose Minimal HDD Required

RAID 0 Striped for Performance. 2

RAID 1 Mirrored for Protection. 2

RAID 5 Parity for Accuracy. 3

RAID 0 + 1 Mirrored and Striped. 4*

Intel’s Matrix Technology 4 logical drives on 2 physical disks, 
to emulate RAID 0 and 1.

2

* Not supported on HP Compaq dc7800 Business PCs.
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NOTES: The following notes are important for RAID configuration:

• RAID 1 is the only RAID configuration that HP Compaq dc7800 Business PC products offer 
as factory configurations.

• The preconfigured systems:

- Are complete RAID systems.
- Have both drives installed.
- Have the necessary Option ROM configuration.
- Are preloaded and preinstalled with all required Intel software.
- Include a preinstalled operating system that is mirrored mode out of the box.

HP Backup and Recovery interactions
After enabling and configuring RAID, restore the system using backup CDs. After completing the restore, 
reinstall HP Backup and Recovery. These steps are necessary for the F11 restore to function properly.

HP also recommends keeping the default options in the RAID Option ROM and in the Windows RAID 
application. Options like “chunk” size for changing the size “stripe” size have more history in their 
defaults settings.

Additional technical information will be provided in the future for customers who want to add RAID soft-
ware image deployment capabilities.

Other supported configurations
HP Compaq dc7800 Business PC products support two other RAID configurations:

• Two hard drive configuration.

• Two equal size/type SATA hard drive RAID configurations in RAID 0 or RAID 1 or Matrix 
Mode of RAID 0 and RAID 1.

• Maximum of two SATA optical drives (on HP Compaq dc7800 Business PC Convertible Mini-
towers).

• Three hard drive configuration (only on HP Compaq dc7800 Business PC Convertible Minitowers).

• Three equal size/type SATA hard drive RAID configurations in RAID 0 or RAID 5 or Matrix 
Mode of RAID and RAID 5.

• Maximum of one SATA optical drives.

Unsupported configurations
HP Compaq dc7800 Business Desktop PC products only support the best user experience and highest 
possible reliability. As a result, HP does not support the following combinations of RAID hard drives:

• Different sizes

• Different speeds (5400 rpm, 7200 rpm, etc)

• Old and new technologies (SATA 1.5 GB and SATA 3.0 GB)

• NCQ hard drives and non-NCQ drives
13



• Different cache size

• RAID combinations of hard drives with any operating system other than Microsoft XP Pro (SP2) using 
Microsoft’s IDE driver stack based on ATAPI.SYS

Configuring RAID on non-factory preinstalled configurations
The remaining sections of this white paper describe steps to set up supported RAID configurations where 
customers have not purchased factory preinstalled RAID configurations. 

Enabling RAID through F10 System BIOS
1. Turn on or restart the computer by clicking Start > Shut Down > Restart the Computer.

2. Press F10 as soon as the monitor light turns green.

If you do not press F10 at the appropriate time, you must restart the computer, and then press F10 
again to access the utility.

3. Select your language from the list, and then press Enter.

4. Use the arrow keys to select Storage. 

5. Use the down arrow key to select Storage Options, and then press Enter. 

6. On the Storage Options menu, use the down arrow key to select SATA Emulation. 

7. Press the right arrow key until RAID displays, and then press Enter.

8. To apply and save changes, select File > Save Changes and Exit.

• If you do not want to apply your changes, select Ignore Changes and Exit.

• To reset to factory settings, select Set Defaults and Exit. This option restores the original 
factory defaults.
14



CAUTION: Do NOT turn the computer power off while the ROM is saving the F10 Computer Setup 
changes as the CMOS could become corrupted. Only turn the computer off after exiting the F10 Setup 
screen.

Configuring RAID Option ROM
You can only access Computer Setup at system startup. To access the Computer Setup Utilities menu and 
enable RAID:

1. Turn on or restart the computer by clicking Start > Shut Down > Restart the Computer.

2. Press Ctrl + I repeatedly as soon as the monitor light turns green to enter the RAID configuration util-
ity. If you do not press Ctrl + I at the appropriate time, you must restart the computer, and then press 
Ctrl + I again to access the utility.

The Intel Matrix Storage Manager screen (RAID Option ROM) displays briefly during boot up. The 
RAID configuration utility is English only. To configure RAID in other languages, use the Windows-
based RAID configuration utility.
15



Configuring RAID Volume using the Option ROM
1. Once you are in the Option ROM, if there are no previous RAID member hard drives, press Ctrl + I 

to enter the RAID configuration utility.
16



2. With Create RAID Volume selected, press Enter to access the Create Volume screen.

3. Select or enter the desired RAID Level. Use the information on the bottom half of the screen if neces-
sary.
17



4. Use the arrow keys to scroll to Create Volume, and press Enter. The following screen appears.

CAUTION: All data on the selected disk will be deleted.

Notes for operating system installation
• After creating a RAID disk volume in the option ROM, you can install the operating system.

• HP provides a download for the required F6 disk for Windows XP CD installation.

• Customer-created images MUST account for the RAID controller.

• Failure to install and enumerate the RAID driver after enabling the RAID controller (with or without cre-
ating a volume) will result in a Windows boot failure (blue screen) for inaccessible boot device.

WARNING: The PCI Device ID of the mass storage controller changes after changing IDE mode. Chang-
ing the BIOS from IDE mode to RAID mode is the equivalent of connecting the hard drives to a new add-
on RAID storage controller. The installed operating system on the hard drive is unaware of this new mass 
storage controller. If the drivers are not available, enumerated, and PnP for this new controller, the operat-
ing system blue screens in Microsoft XP and Microsoft Vista.

Additional technical information will be provided in the future for customers who want to add RAID SW 
image deployment capabilities.
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Intel Matrix Storage Manager software installation
This section of the paper focuses on how to configure RAID using Intel Matrix Storage Manager software. 
The configuration steps are for application usage and supported RAID migrations.

Console Software Installation
The Intel Matrix Storage Manager Software is preloaded in all HP Compaq dc7800 Business desktops at 
“C:\Intel\Intel MSM”. To execute the software, run the setup.exe file. You can also get this software from 
the HP and Intel Web sites.

1. Select Start > All Programs > Intel(R) Matrix Storage Console.

2. Click Next.

3. Read the driver agreement. If you agree, click Next.

4. Read the License Agreement. If you agree, click Yes.

5. Select or browse to a destination folder, and then click Next.  

6. The Select Program Folder window suggests a program folder with Intel Matrix Storage Man-
ager highlighted to add the program icons.

7. Click Next to finish the installation.

8. Click Finish to close the setup.

9. Restart the computer.
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Using the Intel Matrix Storage Console interface
1. Click Start > All Programs > Intel Matrix Storage Manager/Intel Matrix Storage 

Console to open the Intel Matrix Storage Console application. The Intel Matrix Storage Console 
starts in basic mode by default and has three main menus.

NOTE: The report the applications generate is very comprehensive. You can view the report at 
View/System Report. The reports contains information about the driver, operating system, 
language, and hard drive.

2. Select View hard drive and volume Status. 

3. For a more detailed view of the RAID controller, click View > Advanced Mode.

In Advanced Mode, the Intel Matrix Storage Console also includes the Actions menu. Use this menu to 
access the advanced features of the RAID solution.

RAID migrations

Migration to RAID 1 from two non-RAID hard drives using Intel Matrix Stor-
age Console
NOTE: HP Compaq dc7800 Business PC products only support RAID based on two identical SATA hard 
drives in either RAID 0 or RAID 1 or Matrix Mode of RAID 0 and RAID 1.
20



1. Open the Intel Matrix Storage Console and in the left pane select either Protect data from a 
hard drive failure with RAID 1 or Improve storage performance with RAID 0. 

2. In the right pane, select Protect data from a hard drive failure with RAID 1.

3. Click Create a RAID 1 volume to open a verification window. 

4. Select Yes to begin the migration process.

5. Click OK after the migration completes.
21



Degradation 
In the unlikely event that one of your hard drives malfunctions, you will be notified with the following mes-
sage:

1. Run the Intel Matrix Storage Console application on the system experiencing a degradation to iden-
tify the hard drive that failed and to which port it is connected.

2. After identifying the hard drive, close all applications, shut down the operating system, power down 
the unit, unplug the power cord, and replace the defective hard drive.
22



3. After replacing the hard drive, automatic rebuild of the redundancy begins immediately after the sys-
tem is powered up and operating system starts. The following message appears:

Migration to RAID 0 from two non-RAID hard drives using Intel Matrix Stor-
age Console
NOTE: HP Compaq dc7800 Business PC products only support RAID based on two identical SATA hard 
drives in either RAID 0 or RAID 1 or Matrix Mode of RAID 0 and RAID 1.

1. Open the Intel Matrix Storage Console and select Improve storage performance with 
RAID 0. 

2. Click Actions > Create a RAID 0 volume to open a verification window.
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3. Click Yes to begin the migration process.

4. Click OK after the migration completes.

Migration to RAID 0 from three non-RAID hard drives using Intel Matrix 
Storage Console
NOTE: Back up all data before proceeding.

NOTE: HP Compaq dc7800 Business PC products only support RAID based on three identical SATA hard 
drives RAID in either RAID 0 or RAID 5 or Matrix Mode of RAID 0 and RAID 5.

1. Open the Intel Matrix Storage Console and select View>Advanced Mode. 

2. Click Actions > Create RAID Volume from Existing Hard Drive, which opens a verification 
window.
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3. Click Next.

4. Type the RAID Volume Name, select the RAID Level (for three hard drive RAID 0 or RAID 5 only), 
and select the Strip Size.

NOTE: HP currently supports only the default Strip Size (in this case 128KB). There is a performance 
relation between the type of data and the strip sizes.
25



5. Click Next to display the selection of hard drives that will be part of this RAID volume.

6. Select all three hard drives (Port 0, Port 1, and Port 2), and then click the right arrow to place them in 
the Selected box.

7. Click Next.
26



8. Select all hard drive members of the RAID volume, and then click the right arrow to place all three 
hard drives in the Selected box.

9. Click Next. 

10. Complete the volume size selection screen, and then click Next.

NOTE: If users consume all available storage for this RAID volume, there will be no space to create 
another RAID volume for this hard drive, thereby not allowing for Matrix mode RAID.

Note the size if you want to create a second RAID volume in this set of hard drives.

11. To create one RAID 0 out of the hard drive, leave the default of 100% for Percentage of Avail-
able Space, and then click Next. 
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12. Select Finish to start the migration process, which can take a few hours.

After you click Finish, the migration starts and the following screen displays:

13. Reboot the system after the migration finishes.

Migration to RAID 5 from three non-RAID hard drives using Intel Matrix 
Storage Console
NOTE: Back up all data before proceeding.

NOTE: HP Compaq dc7800 Business PC products only support RAID based on three identical SATA hard 
drives in either RAID 5 or RAID 0 or Matrix Mode of RAID 0 and RAID 5.

1. Open the Intel Matrix Storage Console and select View>Advanced Mode.
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2. Click Actions/Create RAID Volume from Existing Hard Drive to open a verification win-
dow.

3. Click Next.

4. Type the RAID Volume Name, select the RAID Level (for three hard drive RAID 0 or RAID 5 only), 
and select the Strip Size. 

NOTE: HP currently supports only the default Strip Size (in this case 64KB).
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5. Click Next to see the selection of hard drives that will be part of this RAID volume.

6. Select all three hard drives (Port 0, Port ,1 and Port 2), and then click on the arrow to move them to 
the Selected window.

7. Click Next.
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8. After the selection of the all hard drive members of the RAID volume, complete the volume size selec-
tion screen, and then click Next.

NOTE: If users consume all available storage for this RAID volume, there will be no space to create 
another RAID volume for this hard drive, thereby not allowing for Matrix mode RAID.

Note the size if you want to create a second RAID volume in this set of hard drives.

9. To create one RAID 5 out of the hard drive, leave the default of 100% for Percentage of Avail-
able Space, and then click Next. 
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10. Select Finish to start the migration process, which can take a few hours. The following screen dis-
plays.

11. Reboot the system after the migration finishes.

Migration to Matrix RAID 5 and RAID 0 from three non-RAID hard drives 
using Intel Matrix Storage Console 
NOTE: Back up all data before proceeding.

NOTE: HP Compaq dc7800 Business PC products only support RAID based on three identical SATA hard 
drives in either RAID 5 or RAID 0 or Matrix Mode of RAID 0 and RAID 5.

1. Open the Intel Matrix Storage Console and select View>Advanced Mode.
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2. Click Actions/Create RAID Volume from Existing Hard Drive to open a verification win-
dow.

3. Click Next.

4. Type the RAID Volume Name, select the RAID Level (for three hard drive RAID 0 or RAID 5 only), 
and select the Strip Size. 

NOTE: HP currently supports only the default Strip Size (in this case 128KB). 
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5. Click Next to see the selection of hard drives that will be part of this RAID volume.

6. Select all three hard drives (Port 0, Port ,1 and Port 2), and then click on the arrow to move them to 
the Selected window.

7. Click Next.
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8. After the selection of the all hard drive members of the RAID volume, complete the volume size selec-
tion screen, and then click Next.

NOTE: If users consume all available storage for this RAID volume, there will be no space to create 
another RAID volume for this hard drive, thereby not allowing for Matrix mode RAID.

Note the size if you want to create a second RAID volume in this set of hard drives.

9. To create two volumes based on your space, reliability and performance needs, select the size of the 
first RAID volume by sliding the bar or entering the desired volume size. For example, divide in half 
the available hard drive storage in two RAID volumes by setting the Percentage of Available 
Space to 50%, so that 50% of drive capacity is used for RAID 0.

10. Click Next.
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11. Click Finish to start the migration process, which can take a few hours. 

12. Reboot the system after the migration finishes.

NOTE: Back up all data before proceeding.

13. After the first RAID volume has been created, create the second RAID volume by opening the Intel 
Matrix Storage Console, clicking View>Advanced Mode, and then clicking Actions/Create 
RAID Volume from Existing Hard Drive.
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14. Click Next.

15. Use the same values you entered in the previous RAID volume confirmation and type the RAID Vol-
ume Name, select the RAID Level (for three hard drive RAID 0 or RAID 5 only), and select the 
Strip Size. 

NOTE: HP currently supports only the default Strip Size (in this case 64KB).

16. Click Next to see the selection of hard drives that will be part of this RAID volume.
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17. Because this is the second volume for this set of hard drives, select the existing name in the Avail-
able box (Array 0000), and then click the right arrow to move this array into the Selected box.

18. Click Next.

The Specify Volume Size screen is grayed out because the second volume of this matrix mode takes the 
remaining space. After the selection of the all hard drive members of this RAID volume, follow the volume 
size selection screen.

NOTE: The first array volume creation is the place for adjusting the size; the second volume will take any 
remaining space.

19. While creating the second RAID volume, click Next to open the completion window.
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20. Select Finish to start the migration process, which can take a few hours. The following screen 
appears.
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21. Reboot the system after the migration finishes.

After the second reboot and both migrations are complete, you can see the state of the Matrix mode cre-
ated by opening the Intel Matrix Storage Console and clicking View>Advanced Mode. The matrix 
mode of three hard drives is illustrated in the following image.
40



Migration to RAID Matrix Mode (0 + 1) from two non-RAID hard drives 
using Matrix Storage Console 
The migration process for two hard drives to RAID Matrix Mode (0 + 1) is very similar to the process 
described in the section about migration of three hard drives to matrix mode RAID (0 + 5). The difference 
in the process is selecting two hard drives as part of the volume created and selecting RAID 5 instead of 
RAID 1.

Installation
HP desktops come with RAID software preinstalled; however, if reinstallation is necessary, use setup in 
combination with the following supported flags:

-?: The installer presents a dialog showing all the supported setup flags (shown here) and their usage.

-A: Extracts all files (does not install driver) to <path> if -P is also supplied. Otherwise, the files are 
extracted to the default location.

-B: Forces a system reboot after installation.

-O<name>: Allows for the customization of the program folder name for the Intel(R) Matrix Storage 
Console, which appears in Start > All Programs.

-P<path>: Supplies target path when using -A flag.

-N: Installs all components except driver.

-NoGUI: Installs only the driver. The Intel(R) Matrix Storage Console, Event Monitor, and Tray icon applet 
are not installed.

-NoMon: Disables the Event Monitor which consists of the Disk Monitor Service and the System Tray 
Icon Applet.

-S: Silent install (no user prompts).

-BUILD: Displays build information.

-G<number>: Forces a particular language install. There cannot be a space between -G and <num-
ber>.

-f2<path\name>: Creates a log file in <existing path> with <name>. Use during silent installation. 
There cannot be a space between -F2 and <path\name>, and the path must exist prior to installation.

Notes:  Flags and their parameters are not case-sensitive. Flags may be supplied in any order, with the 
exception of -S and -G, which must be supplied last. When using the -A flag, a target path may be 
specified using the -P flag, and the -O, -G, -S, and -N flags are ignored. When using the -P, -O, -G 
and -f2, flags there should be no space between the flag and the argument. When using the -f2 flag,  
specify a log file name and path. The path must exist prior to the installation.
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Language support table

ara Arabic (Saudi Arabia) (0401)

chs Chinese (Simplified) (0804)

cht Chinese (Traditional) (0404)

csy Czech (0005)

dan Danish (0006)

nld Dutch (0013)

enu English (United States) (0009)

fin Finnish (000B)

fra French (International) (040C)

deu German (0007)

ell Greek (0008)

heb Hebrew (040D)

hun Hungarian (000E)

ita Italian (0010)

jpn Japanese (0011)

kor Korean (0012)

nor Norwegian (0014)

plk Polish (0015)

ptb Portuguese (Brazil) (0416)

ptg Portuguese (Standard) (0816)

rus Russian (0019)

esp Spanish (000A)

sve Swedish (001D)

tha Thai (001E)

trk Turkish (001F)
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